EE - Forum Styles

Flexim G704 with fieldbus - connect to DeltaV

I have a new Flexim Ultrasonic flow meter that shows flow and other variables (sounds speed, etc.) locally, but in AMS and DeltaV (14.3.1) shows "bad sensor failure". Only temperature and signal strength show "Good". All the other variables, including standard volumetric flow rate, show "bad". Any idea what I am doing wrong? The DD I downloaded from the Emerson website would not load, however the one that was on the media supplied by Flexim loaded okay and I was able to commission the device. I can configure an AI for temperature and it works fine, but flow rate still shows "bad sensor failure". Any thoughts?

  • Does the Block Error parameter give any clue :
    - Block configuration error
    - Link configuration error
    - Device needs maintenance soon
    - Sensor failure
    - Output failure
    - Memory failure
    - Lost static data
    - Lost non-volatile data
    - Readback check failed
    - Device needs maintenance now
    - Power-up
    - Out-of-Service

    If it is block (parameter) configuration error it is usually an invalid engineering unit. user friendly devices only list valid units, unfriendly devices list hundreds of options. Flow can be tricky because you have m3/h, Nm3/h, and Sm3/h etc. and your device may only support one of them
  • In reply to Jonas Berge:

    Jonas - BLOCK_ERR is something equivalent, Sensor failure or I/O Input failure - one of those. Both resource and transducer blocks are in "AUTO". I made sure DeltaV (running 14.3.1) only displayed a limited unit set and I chose one of those (CFH) and set up the transmitter (locally) to do the same. Locally, all the diagnostic parameters look good.
    Transmitter manual states that XD_SCALE and OUT_SCALE must match (they do) and that L_TYPE must be "direct".
    I did not try the "old"method of consulting "help" for "valid units and channels". But I am not getting a "config" error.
    Can I run a DTM in my version of AMS (whatever ships with 14.3.1)? Is that feature separately licensed? The EDDL dialog has very few adjustable parameters.
    Cheers, John
  • In reply to John Rezabek:

    This issue is solved. A factory representative remembered that for the Fluxus G704, fieldbus AI blocks don't connect to the normal measurement channels ("A" and "B") but to the computational channels. The manual is a little misleading in that it states the computational channel ("Y") is only used with dual channel applications (where dual sensor tracks are e.g. averaged for a more accurate flow measurement). Ours is a single channel. So, channel "Y" needed to be enabled (locally - no way to do this through the DD or the DTM*) and its equation set to "(A + A)/2" . . .

    *Indeed I installed the DTM that was on the media that shipped with the meter; used AMS to add it to the catalog and it became an option in the right-click context menu for the instrument. Interestingly - there was nothing you could do with the DTM that you couldn't do with the normal AMS "Configure" EDDL dialog. There are so many parameters and options in instruments like this - it would be great to access them from the system vs. locally.

  • In reply to John Rezabek:

    Good to hear you solved it.

    Strange these settings were not mapped to parameters (in the transducer block) you could set remotely. Would be very convenient like you say. When there are many parameters such as for flow meters and valves, a good EDDL user interface with logical menus and wizards (methods) is critical such that you get the frequently used stuff up front not cluttered by rarely used stuff that should be further down the menu.

    In the future with APL (single pair Ethernet) devices will have an embedded web server so you can access the device settings that way. Learn more about the future APL from this essay: