OWS can not open control studio ang gives Access Denied

Dear All

I have one pro , 2 engineer, 14 ows, one HIST

ows 1, ows 7, ows 13 do not open control studio  giving error Access denied as shown in photo

Note that these stations also could not access online database when using 'DVoperate in configuration mode:

provided that :

1- service password is correct and confirmed

2- when run deltav workstation configuration program it fails to complete and the only way to rerun the OWS is using regall  /register  command




11 Replies

  • Access Denied would likely be caused by not having the DeltaVAdmin user password properly set, preventing those stations from being able to access the database on the Pro Plus. This password is normally set when running Workstation Configuration. It can be reset running servepwd.exe, which applies the new password to all the services that use the DeltaVAdmin account. Altering this password manually on a station will not resolve this issue.

    If you do not know the current DeltaVadmin password for the system, you will have to reset all machines to a known password, starting on the pro plus, and work your way out from there.

    Suggestion: If you do not know the current DeltaVAdmin password, you could confirm that the password is the issue. On one of the machines that is working, change the DeltaVAdmin password thus break this machine's access to the database. Then you can observe if the issue presents in the same way. Then you know that you have to reset the password and that it will fix it. But you really need to know this password anyway.

    If you know it, try setting it on one of the broken machines.

    Andre Dicaire

  • In reply to Andre Dicaire:

    Thanks for your response. Kindly find what I did as follows

    1- I know Deltav admin password

    2- on one of the working good machines I changed the pwd using servpwd.exe to change the password and rebooted but still control studio is working fine so the issue is not only pwd

    3- on the pro I used servpwd.exe to confirm that I have the right pwd

    4- on one mal function ows I used servpwd to change the pwd using the one I know for pro then rebooted but still control studio gives access denied

    5- according to help I need to register services after changing pwd so I use regall /register , it works fine till the last point then it askes for Deltav admin PWD

    and it stops  until I put the right pwd.

    6- after all still same problem


  • In reply to hagouda:

    OK, you've eliminated the deltavadmin password.

    DeltaV core communications explicitly uses the DeltaV primary and secondary networks. Some higher level apps like Control Studio use the binding order to select the NIC and if different on both ends, this can cause issues, though I don't know if this symptom is consistent with that.

    What is the difference between these stations that don't work and those that do? Network connections are the same? Can you ping the Primary and secondary addresses? (networks are not crossed) Different computer models?

    I'd recommend you log a call with the GSC as they can mine the known issues and similar customer calls and resolutions. I'm probably wasting your time with guesses.

    Andre Dicaire

  • Check if DeltaV network is set properly.

    On one of the stations with issue try to restart the machine one more time and do a total download of the station from the PRO+. Check if you can open a module in Control Studio on-line mode.

    In case the issue still exist, disable or physically disconnect all network connections except the DeltaV Primary, this will force all communications to the DeltaV Primary NIC. Do a ping to (PRO+), in case the ping fails then you would need to troubleshoot your network connection to the PRO+.

    In case ping is successful try to open a module in Control Studio on-line mode and see if it opens. In case it opens then you may need to check the NIC binding order of the machine if it is as per Emerson documentation. In case Control Studio fails to open then it can be a security or firewall issue, you may want to check the user access and if the machine belongs to the same domain/workgroup as the PRO+. Check if Windows firewall is disabled on the station. Verify that you are using unmanaged switches or DeltaV smart switches and check if there are recent changes to the DeltaV network that you are not aware of.
  • In reply to Neil Castro:

    Dear All
    Unfortunately I have tried all solutions followup all your recommendations/ steps still getting same issue moreover I compared services between one malfunctioning machine and other working well both have same service status.
    Firewall and windows defender are disabled in both machines

    I am using Emerson smart switches and unmanaged 

    Network is OK all other machines are working well and these machines works well with Deltav operators run mode getting live data, alarm,..faceplate,  open close valves....

    Thanks for your response

  • In reply to hagouda:

    Dear Hossam,

    Have you tried launching Control Studio from the Windows start menu? It should launch successfully without an open module. This would test if there is an issue with the Control Studio application installed in the machine.

    In case Control Studio opens, try to open a module from this Control Studio.
  • In reply to Neil Castro:

    Dear Neil
    Actually I tried to open control studio from windows start menu , from faceplate same results
    Access Denied
    Does this mean that the problem is in the application it self or the application connects at startup with proplus to test license?
    As on other machines with operator license control studio says during opening that "due to license for this machine control studio will open in view only." Then it opens
    The above behaviour is on all working OWS


    ***just a question, Does control studio connects by default to online database/Pro plus during lunching ? Or just check the license on the local machine?

    If so and you know these local files . Can these files be copied from other machine.

    or can we unassigned the license then reassign  again and download?

    If so pls share procedure for doing this


  • In reply to hagouda:

    Dear Hossam,

    This means there is an issue with the Control Studio application as long as the DeltaV and Windows user who is logged in is authorized to open Control Studio. When this application is open in the Windows start menu it does not connect to the database but when it is launched from a faceplate it connects to the database because it needs to open the module that the faceplate is referencing.

    I think a normal Control Studio will always open if it is launched from Windows start menu as long as the user is authorized. You may try to export, delete, and reimporting the OWS node with issue then do a total download but there is a low possibility that this will resolve it.

    You may want to check with IT if they did any restrictions to the OWS or if they did any blacklisting/whitelisting. Check the executable file (C:\DeltaV\bin\dvcs.exe) security that users are allowed to execute or you may compare it with a working station.

    I could not think of any local files or settings in Control Studio that can be reset or recreated. In case you have time you may want to do further diagnostics by opening Control Studio in Windows start menu then note of the time when the access denied error comes up. Open Windows even logs (Application, Security, and System) and see if there are errors/warnings that correspond with the access denied error.
  • In reply to Neil Castro:

    Dear Neil

    Kindly note that I have tried all your suggestions and still same issue  DVCS don't open giving ACCESS DENIED  without any errors generated on eventvwr for windows 

    1. As attached

    Also note I have error also when using Dv operate in  configuration mode it can not access online DB

    also i noted today. That when try to regall /register it works till the end then it asks for DV admin service PWD I input it  then it askes for reboot with oit any results 

    i confirm that this is fhe only pwd used all over the system 

    I double checked with the guy who installed the system  and today I tried on another WORKING OWS

    If you enter any other pwd the system stops refund the wrong pwd and won't complete until entering the right pwd

    Thanks for your Time and support 


  • In reply to Neil Castro:

    When Control Studio is launched from the start menu, it makes a connection to the database, even if no module is defined.

    Below is a connection with user <none> when I launch Control Studio from the Windows Menu and I have not logged into DeltaV.

    Below shows my Control Studio Session when I have logged onto DeltaV with account "AD".

    What this tells us is that your current Windows User credentials are used to open Control Studio on the workstation.  That is, the Windows Login user must have windows access to the Control Studio (CS.EXE) program.  This user must be granted DeltaV access rights to the DeltaV folders, which is done by creating the user through DeltaV User Manager and selecting that a Windows user be created with the same NAME as the DeltaV User.  

    Troubleshooting through an open forum is always going to be a slow and painful process as we offer suggestions that don't pan out because we don't know what you don't tell us.  And telling an open forum about your user security and computer node names is a security risk.  So be careful what you share.

    At this point, it sounds like a windows security issue, since launching Control Studio does not require a DeltaV logon, just the windows logon, which grants you file access on that computer.  When Control Studio launches, it connects to the database and passes the DeltaV user to the database, which determines your DeltaV Privileges such as Can Configure and other database access keys.  With out those keys, Control Studio will be in View Only mode.

    You can logon to a DeltaV workstation with any windows account that Windows recognizes, including local accounts and Domain Accounts.  If the Account is not in the DeltaV group, then launching any DeltaV program will have an Access Denied message.  When you create the DeltaV user, you have a choice to link it to a specific version of the user:  A Local account, a Domain Account, or any user with that name.  The computer may recognize a local or domain user and authenticate it.  But if it does not belong to the DeltaV group on that workstation, you can't launch programs.

    So start by checking that the user is a valid DeltaV account by confirming how it is configured (Local/Domain) and that it is in the requisite security group.

    That other possibility is that the DeltaV programs have had their security altered such that they do not allow DeltaV users to access them, that is, the DeltaV group has been removed from the program's access group.

    If you cannot identify any issue relating to user security or program access rights, I recommend you Uninstall DeltaV and all other programs.  Reboot and start over with a clean DeltaV install, ensuring you properly join the Domain.  That would include Mcaffee and any other programs, support or not.  This is the "I give up " strategy and will not identify the root problem, but it should restore all user and program rights and resolve the issue.

    I still strongly recommend you log a call with the GSC so that you can discuss sensitive user security settings with a limited audience.

    Andre Dicaire

  • In reply to Andre Dicaire:

    Dear Andre

    Thanks for following up. Kindly not that Unfortunately my GSC was expired 

    • I created a new account on user manger and granted all groups and keys
    • I ran workstation configuration utility 
    • It sticked on last phase "registration Dv password " as shown
    • Pls note that pwd is right no way to enter wrong pwd
    • Then the machine lose everything and DV does start after restarting 
    • Then I ran regall /register 
    • It asked for pwd
    • Then it restart 
    • Workspace run mode works well
    • Download from proplus is OK
    • All operation activities is OK
    • Dvcs gives access denied 
    • Workspace configuration mode cannot access online database
    • Meanwhile I cannot reinstall DV and hot fixes as I don't have GSC