• Not Answered

Datalink Modifier [_NOT_CONFIG_OK_]

I can not seem to get this modifier to work. Whenever I switch to the run time, I get the error that the parameter is not configured.  I know it's not. Don't worry about why. I want to use the modifier to suppress the configuration error dialog.  I have done the following:

object is "Datalink1".  Opening the Animations dialogue I set the source as "DVSYS.B-2614/IT1/PV_D.F_CV[_NOT_CONFIG_OK_]". 

The expression parses fine as if i had no modifier, so I trust the syntax is correct.  I don't know what is wrong, but I still get the error.  The HELP topic doesn't show an example, just says to add the modifier to the datalink. Doesn't say where, but I've seen several examples given that show the same method as I'm using. Any help would be greatly appreciated. Thanks!

12 Replies

  • Check to make sure that your display doesn't have other references to that parameter (don't forget the VB scripting) that don't have the [_NOT_CONFIG_OK_] as that is the correct syntax.
  • In reply to Matt Stoner:

    I created a TEMP.grf file that has only the datalink on it.
  • Can you please post the run time error screenshot?
    Just in case - Any spelling mistakes or spaces in the source format?

  • In reply to MPhatale:

    I don't know how to post a screenshot, but it reads as follows:

    Error Number: -1577058245(a200003b)

    that is the source formatting.. I entered the modifier as it is shown in the HELP file and as others have suggested on different threads.
  • In reply to TreyB:

    To add an image in your original post, use the highlighted "Image" icon in the tool bar as shown here: 

    To add an image in a REPLY, choose: USE RICH FORMATTING in the bottom right of the reply window and the tool bar will then appear.

    Then, browse for any image on your phone, computer, etc and  UPLOAD then INSERt.  Once the image is placed, you can also right click on the image to format, resize, etc.

    Best Regards,

    Rachelle McWright: Business Development Manager, Dynamic Simulation: U.S. Gulf Coast

  • Not sure, Are you missing DVSYS. Before the module name?

    Also there just be some error description on the pop up window.

  • Yeah...it's not the configuration related issue for sure.
    Either the network communication is not through or some loading issues.
    Try to reboot the machines.
    Then download the station and pro+ again.

    Should be okay then...

    Good Luck

  • In reply to MPhatale:

    other datalink modifiers work just fine, for instance


    I tried to work around it by changing the data source but I can't seem to get my SUB routine to run prior to the error check. I don't know what run time routine is happening prior, but it doesn't seem I can preempt it.
  • What is this /IT1/ block ? Is that a mistake?
    Try to open the problematic link in watchit or opcwatchit.


  • In reply to MPhatale:

    It is a function block in the module. It's fine. This is all standard issue..

    Even if the path was a mistake.. that is the point. The error would pop up BECAUSE of that. However, the modifier is supposed to suppress that error. I have a single faceplate that I want to use for different module configurations. Some will include a certain AI function block, and some will not. For those modules that don't have that function block, I want to be able to still use the faceplate that references them without having to deal with the error everytime.

    I don't know that explanation helps any.
  • In reply to TreyB:

    Okay, so I wasn't able to get the object modifier to work... BUT . I figured out how to run my sub routine when the run time initializes and change the source for the datalink if it is wrong. I change the source to something I now exists in the configuration and so the error doesn't pop up. This might be a workaround. I still prefer to use the modifier.