DeltaV Live Gem Read only after reinstall, etc.

I had to reimage the Proplus yesterday because i did not have the proper installation media to begin with, I've been running off a generic server 2022 install until Guardian got their corrupt installation media updated. I used Live Administration to backup the database database and then I don't recall if i used Import or Restore after getting everything reinstalled. But, i got all the nodes updated and downloaded and workstation management in order. Thought I was good. 

But now I cannot open faceplates on my graphics. I also cannot search for modules. I can search, but the modules don't show up. So, i don't have a way to open a faceplate. I decided to check on my GEMs and see if there was something weird with the Click interaction. When I opened the GEM in Studio.. it showed this...
"READ ONLY Poet_AI_Transmitter GEM Class is referenced and cannot be edited without a Premium-level DeltaV Live engineering license."

I'm sure this is not a licensing issue.. but I'm not sure how to make these not Read Only. There also seems to be a database sync issue, however my data is all showing up... so the graphic is showing everything correctly. I say database sync because the search tool isn't showing any modules at all. 

DeltaV 15fp1. 

9 Replies

  • We have seen the DeltaV live module issue frequently when adding new control modules.  The workaround we have found is delete one of the module assignments from a controller, then re-assign and re-download the module.  This has worked for us in every instance a new module, or set of modules, do not get populated in the Live database.  Recently Guardian provided us with a SQL script to force the synchronization as well, however we haven't tried it at this point.

    As far as the license issue, the premium performance license is require for class based GEM configuration.

  • In reply to Jesse Delanoy:

    Ummm. So, you are telling me i need a special license to create Gems??? This is news to me and apparently my impact partner.. I'm pretty sure i didn't need one before.. i did most of my configuration of graphics on a system with an integrator key, but i am pretty sure i made some mods on the system without. Hard to say. But that is pretty trash... could you imagine needing a license to modify dynamos??

    Well, thanks for the suggestion, but the unassignment approach didn't help me.
  • In reply to Jesse Delanoy:

    this premium garbage probably explains why my display navigation stopped working..... Wow. So, they expect you to pay for these "features"? Modifying GEMs is one of the most basic things a person would do... Guess i'll be looking for a quote. Still need to get my graphics working in regards to the ability to open faceplates and such. I wonder if a new import of either the configuration database or the Live database might help. I actually have all the .fhx files for the control strategy.. i made those separate from the database backup for the configuration. I guess it can't hurt to try.
  • In reply to TreyB:

    I hear you on the licensing frustration. If you are talking display set navigation, then yes you need the premium license for that as well. We wasted a day troubleshooting an operator station layout file and live configuration, only to find out the premium license had been inadvertently removed which revoked the display set functionality.

    We have always had good luck with the delete assignment method. If that is not working for you I would contact GSC and ask for the AddbListActiveModules.cmd and AddbForceSnapshot.cmd batch scripts, and associated SQL scripts to force the database synchronization from the ProPlus out to every node.
  • In reply to Jesse Delanoy:

    will do. Thanks. They'll probably just ask me for my product support license, which i don't have with this new system. :)
  • In reply to TreyB:

    I reviewed my notes from past DV Live module issues and found this reply from GSC.

    We were able to check with PE and technology team about root cause for this issue.
    As per technology team, Some modules do not appear in Live search because sometimes, the cycle of SQL activities and ADDB activities gets out of sync between the Proplus and Op stations. Performing service startups, adding new nodes, commissioning, or downloads causes bursts of SQL read/write activities which sometimes causes it to lag behind ADDB scan cycles (these can be seen in logs). When this happens, the issue can be resolved by either rebooting the node, re-assigning and re-downloading the module/s, or running the addbforcesnaphot tool to force the replication or creation of the snapshot DB in the Op stations.

    I hope this explains why search modules does not work some times and gets resolved after workaround. Let me know If you have further questions on this.

    Thank you.

    Best Regards,
    Technical Support Engineer | PSS: Global Service Center
  • In reply to TreyB:

    Trey, just so you know, in the table Jesse provided, there are two licenses, one for the Pro Plus (Configuration Environment) and one for the Workstations (Runtime Environment). The Pro Plus premium license does not deliver the runtime environment functionality. Each workstation needs the Premium license to enable the runtime features on each node.

    There are some use cases where an HMI does not need Hierarchy Navigation or other features, but I always discuss this with my customers before removing this license. Omitting either of these licenses without prior discussion with the customer is a recipe for disappointment.

    Andre Dicaire

  • In reply to Andre Dicaire:

    Yeah, i see that distinction. I'm waiting on the quote.. still working through the fact that i can't open faceplates or search for modules in Live. I've been through a couple more workstation configs and other things. I can always configure Gems on our lab machines, so the only thing I am really missing is the navigation. But, that issue is my misunderstanding and not really the problem right now. Curiously, I CAN open function block contextual displays. But module level.. nope. Whether it's from a new display, with OOB Gems or custom, with OOB faceplates or custom. Doesn't seem to matter. Of course, I went into Operate Run and it all had no problem. So, I'm not yet sure where my Live issue is
  • In reply to TreyB:

    Tossed the integrator key on just for fun. Was nice to see my navigation bar return, but yeah. Same issue with contextual displays and the search.