viewonly user is able to acquire operations and able start batch


We ha very strange problem in DeltaV Batch  

We have created 'viewonly' user,  no keys are assigned and not a member of any user group.

This viewonly user is only to view operate run and not to operate and control only for viewing.

This viewonly user functioning as per the requirement,

but i want to make notice that : Viewonly user can not create and start procedure and unit procedure from batch operate interface but unfortunately it is  able to add operations from batch operator interface and start also. 

So i want to know, how we can stop it to create operations and start from batch operator interface.

4 Replies

  • Can you try to do the same from BatchListView operator graphic to see if you can load operations from there as well?

    Based on your writeup, this appears to be an batch operator interface application issue that should be fixed. You should log a call with the Global Support Center for this issue.
  • In reply to Matt Stoner:

    We had a similar issue on a previous project. The Batch Operate Key is granted on a per area basis. A non batch operator could load a batch and even start it. He could not however assign it to run on any unit. The BOI immediatly prompted for the unit assignment.

    The operator then could only assign the operation to run on a unit where he had security access. The overall net effect was a non issue in terms of security. We logged this with Emerson for consideration in future releases. The issue was handled onsite via SOP.

    Can you confirm that phases will not actualy run on a unit due to the operation being started. If phases will actually start can you tell us what version of DeltaV you are using.

    Also if you have changed some batch related secuity functions from the default Batch Operate Lock I would be very interested to know which functions were changed.
  • In reply to Steve Linehan:

    I have tried, it really runs (mean phase is loaded and becomes running). we are using DeltaV Version 11.
    We didn't changed Batch operate Lock, it is as per the default setting.
  • In reply to Hemant ikhar:

    Go through the list of batch functions in the security settings and verify that they are all assigned to the BATCH_OPERATE lock. These functions are called BATCH_LOAD, BATCH_ABORT etc. If these are all assigned to the right lock then that is not the issue.

    I have not seen this before but in previous projects we assigned the NALM field to USER_LOCK_xx (xx = one of the unused locks on your site). We assigned that key to the VIEW_ONLY user. And all other groups in the plant. That gave the VIEW_ONLY user visability on alarms but not the ability to acknowledge them or perform control functions.

    You could see if this makes a difference as mabye this is specific to a user with zero keys. If this works still report the issue as this could be a tempory workaround.

    Also have you tried loading operations from the batchlistview graphic as recommended by Matt.

    One other thing is to ensure your system is patched to the correct level as recommended by Emerson. Emerson issue hoxfixes to correct known issues and this may have already been identified. Contact your local Emerson rep to get these hotfixes.