Control Studio Phantom session issue

UPDATE:  Solved. I remembered that the user account I was using was recently renamed. I guess it doesn't like that. So, i created a new user and i don't have the same issue with it. I will delete the old one.

EDIT: This is not an issue unique to remote session. I cannot add a function block to a module even on a local session. 

IT has setup remote access through Cisco IoT Dashboard. I can use a remote desktop connection through the web app or I can connect to a VPN and use a native RDP session or VNC. No matter what method I connect with, Control Studio tells me that a user on a node is already editing the module in question. Well, yeah.. I"M THE USER!!!  But, it treats it like someone else is doing it. and no, no one else is. There are no other active database connections. i've killed all connections, checked there are no other remote clients connected, etc. No one else even has the password, I'm the only one editing anything. I can still do graphics changes of course since multiple people can have displays open, i believe. Not sure where this issue is stemming from. I have informed IT to look into the Cisco side of things. 


2 Replies

  • That's bizarre.

    Does the same thing happen if you are locally accessing the station? Is the issue only happening via the remote session connections.

    Can you launch Explorer? What connections do you see then in database connections?

    Sorry I can't think of what would be causing a "shadow" connection in the database that locks your session's access to a module.

    Andre Dicaire

  • In reply to Andre Dicaire:

    no, locally, it works just fine. I tried something else. I VNC'd into the proplus, same issue since i'm still connecting through the Cisco. But, then i opened another VNC within the Proplus VNC session and connected to a workstation. I have the same problem there too.. so it's almost like it remembers the origins. lol. I tried some other things and I'm able to modify existing stuff like modify an interlock and then i can even download. What it won't let me do is add function blocks. I will have to try again locally, because i'm not sure if i have tried adding any function blocks lately. It might have nothing to do with the remote access. Of course, the machine is 60 miles away, so i'll have to wait until next week.